Dienstag, 4. August 2015

HP SSM und fehlende Silent Installation von Intel Treibern

Wir nutzen HP SSM zur Nachinstallation von gerätespezifischen Treibern für unsere HP Elitebooks.
Nachdem eine neue Generation (850 G2) bestellt wurde, kam es bei der unbeaufsichtigten Installation zu Meldungen.

"Intel Multiple Package Installation Tool" meldete, dass es den jeweiligen Treiber erfolgreich installiert hat.

Betroffen waren die SP:

sp69959.exe "Intel 7260_3160 Wireless LAN Driver"
sp69976.exe "Intel Bluetooth driver"

Nach einiger Analyse stellte sich durch die Nutzung von Sysinternals "Process Explorer" heraus, dass beim Kommandozeilenaufruf, welcher an den Installer übergeben wurde, der letzte Buchstaben verloren geht.

Betroffen war die Version 3.2.2.1 unter Windows 8.1. Eine älter Version 3.0.6.1 zeigte das Verhalten nicht.

Workaround 1: Ältere SSM Version nutzen

Workaround 2: Die jeweilige .cva anpassen:

Den Eintrage:

SilentInstall="InstMultiPkg.exe" /silent

durch

SilentInstall="InstMultiPkg.exe /silent"

ersetzen.
Interessanterweise wird das dann nicht so aufgerufen sondern am Ende kommt beim Installer die Kommandozeile an:

"InstMultiPkg.exe" /silent

Aber wenigstens fehlt dann das "t" am Ende nicht mehr.

Schön dass solche Hersteller noch Aufwand in die QA stecken...

Kommentare:

  1. Vielen Dank für den Beitrag! Hat mir sehr viel Arbeit erspart (auch wenn ich schon Stunden ins Troubleshooting gesteckt habe!)
    Danke!!

    AntwortenLöschen
    Antworten
    1. Das freut mich.
      Habe selbst festgestellt dass ich bei fast jedem unbekannten Fehler erstmal Google nutze.
      Und dann ist es halt sinnvoll wenn man nichts findet und das Problem löst, die Lösung kurz im Internet zu veröffentlichen.

      Löschen